Cannot see Google map from profile

Status: 
Open
Question: 

I am not able to see my google location on my profile page
I have the following config:
1. Enabled GMap, GMap Location, Node Location and Location.
Note: Only when I turn on Node Locations do I get the "Locative information" group to fill in the details. I filled these in via the edit Profile content type.

2. I then went to edit my Profile Panel content and under:
admin/panels/panel-page/profile/edit/content
I added a Location Block below my current Avatar (i.e on the left hand side of the panel) with the Map macro for profile text field set to [gmap |width=100% |height=200px |control=None |zoom=3|behavior=+notype] i.e. from the book.
Put access to authinticated, saved and went to my profile page. No display of google map.

Help please

Responses

1. Did you edit your profile and

Did you edit your profile and fill in your location information after adding this?

2. Yes I have the following setup

In my Edit profile Tab, I have the following:

Location
Delete checkbox - Check this box to delete this location. (not checked)
City : London
State/Province: empty
Postal code : empty
Country : United Kingdom

Personal Information
Gender:
Date of Birth:
About me:

Avatar

**************************************************

In My Profile I get the following: (based from book)
Left hand side
Avatar displayed

Right hand side
Location:
london
See map: Google Maps (only link to map NOT the map itself)

Personal Information
Gender:
Male

Your rating: